Monday, March 27, 2006

Ruby on Rails with FreeBSD 6.0

FreeBSD doesn't come default installed witht he latest Ruby 1.8.4. So we should probably upgrade our ports first.

Step one, pkg_add -r portupgrade.
Step two, portupgrade -ai.
Step three, portupgrade -R ruby1.8

That will install the latest Ruby 1.8.4, as easy as one two three, right. :D

Then,
portinstall ruby18-gems
gem update --system
gem install rails --include-dependencies

With that you should have the latest Ruby on rails in ya FreeBSD.

2 comments:

Anonymous said...

Thank you :)

tauraz said...

This post is really a gem for me, thanks a lot :)